Friday, 12 May 2017

On 01:15 by admin   No comments
Security specialists from Alephsecurity found new insignificant vulnerabilities (CVE-2017-5948, CVE-2017-8850, CVE-2017-8851, CVE-2016-10370) on OnePlus One/X/2/3/3T OxygenOS and HydrogenOS.
They vulnerabilities influence with the most recent versions (4.1.3/3.0) and beneath.
This vulnerability reported to OnePlus Security on January 26/2017, by Roee Hay from Aleph Research.
OnePlus group neglected to meet the standard 90-day divulgence due date and furthermore the 14-day expansion so the security specialist preferred to go in Public.
These vulnerabilities still remain unpatched.

Downgrade attack CVE-2017-5948

Sadly, every version of the OnePlus OxygenOS and HydrogenOS is vulnerable against downgrade attack.
Occurs because of failure in rendition check in the update, update script in OnePlus OTAs failed to check that the present version is lower than or equivalent to the given image’s.
Attackers can install HydrogenOS over OxygenOS and the other way around, which expands the attack surface.
These vulnerabilities can be exploited over MitM as the update procedure doesn’t happen over TLS association.
Affected products OnePlus 3T, OnePlus 3, OnePlus 2, OnePlus X, OnePlus One.
The researcher published Poc(Proof of concept) in GitHub.

Crossover Vulnerability CVE-2017-8850

This flaw which influences OnePlus 3T, OnePlus 3, OnePlus 2, OnePlus X, OnePlus One is sensibly same, however with this vulnerability, attackers can even replace the OS HydrogenOS over OxygenOS or Viceversa.
This should be possible even on bolted bootloaders in light of the fact that both ROMs utilize the same OTA and check keys.
PoC(Proof of concept) can be found on GitHub.

Crossover Vulnerability CVE-2017-8851

This defect which influences OnePlus X, OnePlus One is sensibly same as the over two, attackers can even replace the OS HydrogenOS over OxygenOS or Viceversa the actuality both items have the same ro.build.product framework property.
Poc(Proof of concept) can be found on GitHub.

OTA Lack of TLS Vulnerability CVE-2016-10370

The most exceedingly terrible part is that the device manufacturer doesn’t utilize Encryption channel to check for OS and security updates.
They use to send JSON ask for tohttp://otac.h2os.com/post/Query_Update or to http://i.ota.coloros.com/post/Query_Update in order to check if another OTA is accessible.
As there is a lack of TLS Man-in-the-Middle attackers is possible and therefore, attackers spoof this response in order to exploit CVE-2017-5948, CVE-2017-8850 & CVE-2017-8851.

Mitigation

Till now all these vulnerabilities still remain unpatched. As we know these MitM attack will be possible only if both the parties connected with the same network.
So avoid using Public or untrusted wifi networks, you can check out our Kalitutorials page for different types of MmitM attacks, impacts and preventive measures.

0 comments:

Post a comment